Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

My Rules does not show all delegated rules

SA-25893

Summary



The My Rules section is not showing all of the rules which have been delegated to the access group.


Error Messages



Not Applicable.
 

Steps to Reproduce

  1. Delegate a few Dynamic System Setting rules to an access group.
  2. Log in as a user with multiple access groups.
  3. Switch to the access group with the delegated rules.
  4. Open My Rules.


Root Cause



A defect in Pegasystems’ code or rules. The Data-Gadget.PopulateMyRules uses the OperatorID.pyAccessGroup value to obtain the list of rules delegated to the access group. This is the default access group for the operator and not necessarily the current access group.

Resolution



Save the Data-Gadget.PopulateMyRules activity in your ruleset and change step three to use AccessGroup.pyAccessGroup.

 

Published August 3, 2016 - Updated October 8, 2020

Was this useful?

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us