Support Article
no clipboard access Using System Management Application (SMA)
SA-2075
Summary
User was unable to access a Clipboard from “Requestor Management” in System Management Application (SMA).
Error Messages
“Access to the MBean operation/attribute RequestorManagement.Clipboard[java.lang.String] has been denied. If you believe that you should have access to this operation or attribute, please check your MBean security settings or contact your System Administrator.”
Steps to Reproduce
- Launch SMA.
- Click Requestor Management.
Root Cause
MBean security configuration in prmbeans.properties were set as true. By default, the value is "true" -> denying access to the Clipboard/Details/etc.
Resolution
Following instructions would help update MBean security configurations related to the Requestor Management:
1. Navigate to <PRPC_distribution_dir>\archives and extract the "pegadbinstall-classes.zip" to a temp folder.
2. Locate and extract the "prmbeans.properties" file under the temp/lib/pega/prresources.jar
3. Modify the prmbeans.properties file values as per the requirement and Re-Jar the prresources.jar with this updated prmbeans.properties.
# Updated MBean security configurations
deny.DatabaseManagement.DatabaseConnectionDetails = false
deny.RequestorManagement.RequestorDetails = false
deny.RequestorManagement.Clipboard = false
# By default, the value is a "true" -> denying you access to the Clipboard/Details/etc.
deny.DatabaseManagement.DatabaseConnectionDetails = false
deny.RequestorManagement.RequestorDetails = false
deny.RequestorManagement.Clipboard = false
# By default, the value is a "true" -> denying you access to the Clipboard/Details/etc.
4. Login to the PRPC Developer portal, navigate to Pega > Application > Distribution > Import menu.
5. Load the prresources.jar (updated version) and click Next.
6. In the Codeset Name/Version screen, specify Codeset Name as "Customer" and Codeset Version as "07-10-13" (this will be different for different PRPC versions) and click "Next" to complete the installation by clicking on "Done".
7. Stop the PRPC server/JVM.
8. Login to the PRPC database as the PRPC schema owner and execute the following SQL command -
SQL > update pr_engineclasses set pzcodeset='pega-enginecode' where pzclass like 'prmbeans%' and pzcodeset='Customer';
SQL > commit;
SQL > commit;
9. Restart the PRPC Server/JVM.
Published January 31, 2016 - Updated October 8, 2020
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