Support Article
Order of error messages for 'Required' fields is incorrect
SA-9152
Summary
User is seeing the error messages in incorrect order for required fields on a case type which is validated through a validation rule.
Error Messages
Steps to Reproduce
- Create a Case Type with 1 Stage.
- Add a Step to Stage and mark it as a 'Single Step Assignment".
- In Process Outline, specify a Flow Action and create it. Create a Section with few fields and reference it in Flow Action. (Configure section to have a "Dynamic Layout": "Inline Grid Triple" and add 4 fields - just as an example).
- Create a Validate rule and configure it to have the fields in the same order as in Section and configure the Validation Condition as "Required".
- Reference the Validate rule created in Step-4 in the Flow Action.
- Save the Process Outline and Go back to Stages.
- Run the Case Type.
Root Cause
This is an out-of-the-box expected design behavior.
Resolution
This is an expected design. Pega will catch all the error messages and display it. It does not sort in order.
Published January 31, 2016 - Updated October 8, 2020
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