Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Pega API fails to update cases

SA-42634

Summary



When the Pega API is used to update an existing case, it fails with the below errors.


Error Messages



API response:
HTTP 500 Internal Server Error

PegaRULES log:
API error: pyUpdateCaseDetails is not part of assignment actions


Steps to Reproduce

  1. Enable the Pega API per Getting started with the Pega API.
  2. Open the API page in Designer Studio via Resources > Pega API.
  3. On the "Update a case" section, fill the ID, If-Match, and requestBody fields with valid inputs from an existing case.
  4. Click on the "Try it out!" button.


Root Cause



An issue in the custom application code or rules. The out-of-the-box flow pyUpdateCaseDetails was removed from the case. This flow is created by default for all new cases, and the Pega API calls this flow when a case is updated with the PUT method.

Resolution



Perform the following local-change: Add pyUpdateCaseDetails back to the case actions.

Published August 26, 2017 - Updated October 8, 2020

Was this useful?

33% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us