Support Article
Pega application is slow and unresponsive at 3 PM AUS time
SA-61695
Summary
Application's performance degrades and does not respond between 15:00 – 15:10 Australia Time. This occurs on a daily basis.
Error Messages
Not Applicable
Steps to Reproduce
Unknown
Root Cause
A defect in Pegasystems’ code or rules.
In the Alert logs, at exactly 5 AM GMT, multiple System calls occur to the below activities,
- pzPersistSystemInfo
- RuleUsageSnapshot
- PushDBIndexes etc.
In the System Management Application (SMA), the following agents are configured to execute at 3 PM AUS or 5 AM GMT:
PegaAESRemote | 2 | PushDBIndexes |
PegaAESRemote | 3 | PushGuardrailData |
Pega-RulesEngine | 0 | PurgeAssemblyDatabaseCache |
Pega-RulesEngine | 6 | PersistSystemInfo |
Pega-RULES | 3 | RuleUsageSnapshot |
Pega-LP | 0 | CalculateComplianceScoreDaily |
Pega-LP | 1 | PurgeComplianceScores |
Pega-LP | 2 | CalculateHistoricSpecificationData |
Pega-LP | 3 | PurgeSpecificationData |
Resolution
Perform the following local-change:
- Configure all the agents to execute out of business hours such that they do not impact the users and the operations during work hours.
- Disable the agent using the below steps:
Disable the PersistSystemInfo agent in the Agent Schedule for each node.
Note: The agent is already deprecated and not in since Pega Platform 7.3.
For more informaiton, refer to the following:
- https://community.pega.com/support/support-articles/deadlock-during-spprpurgetable-cleanup-prlogsystemstate
- https://community.pega.com/knowledgebase/articles/working-agents-pega-73 (Search for PersistSystemInfo agent. The agent is deprecated.)
Published August 19, 2019 - Updated October 8, 2020
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