Support Article
Pega CTI logs generated at wrong location
SA-12209
Summary
The requirement is to configure the PegaCALL application to generate the PegaCTI log file in a desired directory. How can this be achieved?
Error Messages
N/A
Steps to Reproduce
N/A
Root Cause
By default, the system will generate the PegaCTI log file in the Application Server directory. To achieve the requirement, the prlogging.xml needs to be updated with PegaCTI entries.
Resolution
In prlogging.xml, add the below entry and restart the server.
<appender name="CTI" class="com.pega.pegarules.priv.util.DailySizeRollingFileAppenderPega">
<param name="FileNamePattern" value="'your_desired_location_path/PegaCTI-'yyyy-MMM-dd'.log'"/>
<param name="MaxFileSize" value="50MB"/>
<layout class="com.pega.apache.log4j.PatternLayout">
<param name="ConversionPattern" value="%d [%20.20t] (%30.30c{3}) %-5p %X{stack} %X{userid}- %m%n"/>
</layout>
</appender>
<category name="com.pega.pegacti" additivity="false">
<priority value="debug"/>
<appender-ref ref="CTI"/>
</category>
Published July 15, 2015 - Updated December 2, 2021
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