Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

PEGA0046 alerts in Pega CS application D_Campaigns data page

SA-43925

Summary



PEGA0046 alerts occur for the D_Campaigns data page when using the Pega Customer Service (Pega CS) application.

Error Messages



PEGA0046 alerts


Steps to Reproduce



Unknown


Root Cause



A defect in Pegasystems’ code or rules whereby the D_Campaigns data page was referenced before the completion of the asynchronous load. This resulted in a synchronous load.


Resolution



Perform the following local-change: 
  1. Save As the out-of-the-box Rule-PegaCA-Intent-Campaign.CPMEvaluateCampaigns activity into an application ruleset.
  2. Add a Pool ID in the Load-DataPage step.
  3. Save As the out-of-the-box Rule-PegaCA-Intent-Campaign.CPMFilterCampains PegaCS activity to an application ruleset.
  4. Add a Connect-Wait step to use the Pool ID (added to the Load-DataPage step inCPMEvaluateCampaigns) and wait for 10 seconds.

 

Published October 8, 2020

Was this useful?

50% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice