Support Article
PegaAPI call fails to create Interaction work items
SA-59504
Summary
Error occurs while creating Interaction cases when using the PegaAPI.
Error Messages
Pega_API_008 Case Type not found for the given parameter caseTypeID Create a new case
Steps to Reproduce
- Set up PegaAPI and use the following:
post /cases Create a new case
- Pass the Interaction class as caseTypeID, and processID as CPMInteraction, in the request body.
{
"caseTypeID": "PegaCPMHC-Work-Interaction-InCorr",
"processID": "CPMInteration",
"parentCaseID": "",
"content": {}
}
Root Cause
Customer Service for Healthcare 7.1.3 was initially released on Pega 7.1.7 where PegaAPI for case creation was not available.
Resolution
Update to a higher version of Customer Service for Healthcare.
Tags:
Published July 23, 2018 - Updated December 2, 2021
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