Support Article
Poor performance with Connect SOAP integration
SA-10906
Summary
Poor performance experienced with Connect SOAP integrations. The external SOAP service takes a long time ( more than 15 seconds) to complete the response.
Error Messages
Not Applicable
Steps to Reproduce
Run a SOAP connector.
Root Cause
The root cause of this problem is in a third-party product.
Both the PEGA0020 alerts and your own call through the SOAP UI, indicates that the root cause of the delay is in the time it takes for the external system to complete the response. This is represented in the following PAL stats which you can access in the PegaRULES-ALERT log. The 'pxConnectClientResponseElapsed' counter reflects the time it takes the external system to respond in milliseconds:
pxConnectOutMapReqElapsed=11;
pxConnectClientResponseElapsed=64797;
pxConnectInMapReqElapsed=1092;*
Resolution
There is no defect or performance issue within the Pega server. Provider of the external SOAP endpoint must help resolve this issue.
Published August 6, 2015 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.