Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Procedure to send email with images

SA-9198

Summary



User requires to know the procedure to send emails with images in them that do not show up as attachments or "?" on the email client ?.

While trying to send an email correspondence with image in it, at that moment the email either shows as attachment or "?" on the email client (Gmail, Outlook etc).



Resolution



The explanation for this behaviour is as follows:

Following approach is Out-Of-The-Box (OOTB) way of sending emails with attachments (In this case it is image)
 
1. Image or Attachment must be attached to WorkObject using AttachContent smart shape or OOTB activities.

2.While attaching this image, map this attachment to some new Attachment Category (for example, EmailAttachments).

If you are sending emails via SendEmail smart shape or CorrNew activity then both of the options provide ability to Send email with attachments.
  • CorrNew activity takes AttachmentCategoriesToSend as parameter where you can specify comma separated values (In this case you require one image so only EmailAttachments)
  • SendEmail smart shape also has same option.( Find below the screenshot for details )



 
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

50% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us