Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

pxUrgencyWork is empty for cases created using a dataflow

KCP-547

Summary


The value of pxUrgencyWork property is empty for cases that are created using a dataflow. However, the value of pxUrgencyWork is set for cases that are manually created.

 

Error Messages


Not Applicable

 

Steps to Reproduce


Unknown

 

Root Cause


An issue in the client application code or rules.
When the value of pxUrgencyWork is set, the value of Urgency is displayed on the UI. However, the value of pxUrgencyWork property is set if the Work-.pxUrgencyWork declare expression is triggered. If a dataflow is used to create a case, the declare expression is not triggered because no forward chaining occurs in the dataflow. Hence, the value of pxUrgencyWork property is empty. However, if a case is manually created, the value of pxUrgencyWorkClass is updated. Therefore, when a service-level agreement (SLA) is triggered again, the Work-.pxUrgencyWork declare expression is invoked because the value of pxUrgencyWorkClass is considered than that of pxUrgencyWork property.

 

Resolution


Here's the explanation for the reported behaviour:
Dataflows do not support declare expressions. Running an activity in a dataflow context disables the inference engine that is responsible for triggering declare expressions.

  

Published December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us