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Support Article

pyTreatment & pyReason saved as NULL in IH dimensions (outbound)

SA-13996

Summary



pyTreatment and pyReason values are not stored in the Interaction History (IH) Channel and Context Dimension respectively.


Error Messages



Not Applicable


Steps to Reproduce



1. Configure and run an outbound Pega Marketing Program.
2. Batch records & IH Fact records are created as expected.


Root Cause

pyTreatement and pyReason are set in the Strategy but not written to IH.


Resolution



Apply HFix-23504. You can set pyTreatment and pyReason from Strategy using set shape. Or, this can also be set on the Connector in the Offer shape.

Published September 11, 2015 - Updated October 8, 2020

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