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Support Article

RC90 CC1b Partial Dispute - Pega Changes Dispute Amount

SA-9325

Summary



The Dispute Amount Entered in the Enter Dispute Details Screen is changed by the system and instead, the Dispute amount is calculated based on the difference between Amount Received and Amount requested values entered on the Answer Ancillary Questions screen.
Foreign transaction Dispute Amount and Chargeback Amount differ; so transaction processors receive different values.
Calculation for Chargeback Amount is performed in Declare Expression rule for ATM Disputes.

Class: PegaCard-Sd-Dispute-Visa-International-
Name: ChargebackAmount

ChargebackAmount = (.ATMAmtRequested - .ATMAmtReceived)/.BasicCurrencyConRate


Error Messages



Not Applicable

Steps to Reproduce



1. Launch Smart Disputes for Visa transaction with Non-TD ARN and MCC 6011.
2. Enter desired dispute amount value in to "Enter Dispute Details" screen. Click Submit.
3. Select RC90 CC1b on "Choose a Reason Code" screen.
4. On the "Answer Ancillary Questions" screen:
  • Yes - Is the chargeback amount limited to the portion of the transaction for which the chargeback right exists?
  • Yes - Was Partial cash or Load Value received?
  • Amount Received: enter amount
  • Amount requested: enter amount
5. Click Submit. Process Chargeback screen displays dispute amount as the difference between Amount Received and Amount requested values entered on the Answer Ancillary Questions screen.
6. Click Submit. Dispute Confirmation screen displays dispute amount as the difference between Amount Received and Amount requested values entered on the Answer Ancillary Questions screen.
7. Complete dispute.
TSYS Adjustment posted for amount as the difference between Amount Received and Amount requested values entered on the Answer Ancillary Questions screen.
VROL Questionnaire displays dispute amount as the difference between Amount Received and Amount requested values entered on the Answer Ancillary Questions screen.
8. Complete dispute.


Root Cause



The root cause of this problem is a defect in Pegasystems’ code/rules.

Resolution



Apply HFix-21854.

Published November 17, 2015 - Updated October 8, 2020

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