Support Article
Records for final four hours are missing in the BIX Extracts
SA-83081
Summary
While extracting records through a Business Intelligence Exchange (BIX) using an agent scheduled to execute at 12 AM, the records created or updated during the last four hours of the day, (that is, after 8 PM) are missing in the extraction. These records are extracted in the next day's execution.
Error Messages
Not Applicable
Steps to Reproduce
- Create a BIX extract to generate a list of all work objects created since the last runtime.
- Check the 'Use last updated time as start' checkbox.
- Create new work objects after 8 PM.
- Schedule the agent to execute the BIX extract at 12 AM.
Root Cause
Since the 'Use last updated time as start' checkbox was checked, the records which must be fetched should have the pxCommitDateTime lesser than the SYSDATE according to the query generated for the BIX Extraction process.
Since the pxCommitDateTime had a +4 hours entry in the database for each record, the records that are created after 8 PM have the pxCommitDateTime greater than the SYSDATE (that is, after 12 AM). Hence the records are not fetched. The incorrect entry in the database is the result of the difference in the database server time zone (UTC) and the application server time zones (EST) which are not in sync.
Resolution
Perform the following local-change:
Sync both the Database server and the Application server time zones.
Published August 19, 2019 - Updated December 2, 2021
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