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Support Article

Requestor Pool locked

SA-82102

Summary



Requestor pool locked errors occur and sessions are not free and requestors are not idle. This occurs with the two services below,

-Delegate Service (Custom application service)
-Monitor (Pega's out-of-the-box service)


Error Messages



Alerts from the Predictive Diagnostic Cloud (PDC):

1. Requestor Pool Locked (RequestorPool-14)
Requestor pool locked for DelegateService

Description
Unable to process a service request for pool / package DelegateService - pool was locked

2. (RequestorPool-1)
Requestor pool locked for monitor

Description
Unable to process a service request for pool / package monitor - pool was locked


Steps to Reproduce



Not Applicable


Root Cause



A defect or configuration issue in the operating environment.
The Requestor pool was full. 
The errors occurred due to authentication. Hence, the requestors were not returned to the pool.


Resolution



Perform the following local-change:

Ensure that each instance has a separate service account.

Published August 19, 2019 - Updated December 2, 2021

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