Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Rule resolution does not pick up rule

SA-104405

Summary

CPMRecentInteractionInfoWithType section is present for PegaCA-Work-Interaction. However, the rule resolution does not pick up the rule and an error occurs. This occurs while using Pega Customer Service for Financial Services 8.3 on Pega 8.3.


Error Messages

ERROR - Could not find a rule when appending a stream;com.pega.pegarules.pub.generator.RuleNotFoundException: Failed to find instance @baseclass.CPMRecentInteractionInfoWithType of type Rule-HTML-Section.;


Steps to Reproduce

Launch a new interaction which does not have interactory history.


Root Cause



A defect in Pegasystems’ code or rules. The issue occurs when the Interaction created for a member ID does not have any recent interactions. The section includes CPMRecentInteractionInfoWithType that runs in the context of the data page. When there are no results, it performs a search in the hierarchy of the parent section. An error occurs since it is unable to find the section in the hierarchy.

Resolution



 Apply HFix-61501.

 

Published March 27, 2020 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us