Support Article
S-case does not display as completed on clicking close/cancel
SA-56406
Summary
Service case (S-case) does not display as completed after clicking close/cancel. This occurs sporadically when the left panel is not updated as completed.
Error Messages
Not Applicable.
Steps to Reproduce
- Open a S-case
- Click the Cancel button
- Click some other action before the screen refreshes
Root Cause
An issue in the custom application code or rules. The custom button called a refresh section before calling the Cancel action. The section refresh and the immediate action after that resulted in a race condition.
Resolution
Perform the following local-change:- Replace the 'refresh section' action with a 'run activity' which executes faster. It also does not refreshes a section which is simultaneously being removed
- Add a call to the top.showCPMBusyIndicator script as the first action of the configured button
- Set a source parameter of 'driver' in the top.showCPMBusyIndicator script. This displays a busy indicator which prevents the user, no matter how fast, from clicking on an additional action before the cancel takes effect
Tags:
Published July 23, 2018 - Updated December 2, 2021
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