Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Screen unresponsive on entering incorrect Date type with /

SA-100850

Summary



On entering an incorrect Date type with '/' in the datatype name, the the screen is unresponsive and does not load. The user must refresh the browser or logoff and relogin to the application.


Error Messages



Exception caught while evaluating When


Steps to Reproduce

  1. Configure a DateTime property with Display details read only selected.
  2. On change, run a data transform.
  3. Add a step, in the data transform, with a When condition.
  4. Enter invalid text for the date (for example, 3.34/543/.53/.453./4).


Root Cause



An issue in the custom application code or rules.
The Date string was compared with another Date in the When rule.
The When rule is executed even though the Date format is incorrect. Hence, the exception displayed during the Date comparison.



Resolution



Perform the following local-change:

Since Pega validation displays a Page error message on Invalid Date entered, before execution of the When rule which compares the Date in the data transformation, include a step to determine if the page has error message using the 'hasMessage' When rule.

Published February 12, 2020 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us