Support Article
Search Index not working for new items after upgrade to Pega 8.1
Summary
After a system upgrade from Pega 7.3 to Pega 8.1, users report that the Search Index is not working. The Search Index agent (pyFTSIncrementalIndexer) lists many items in its queue, but none of them are processed. After the system is restarted, all existing records are indexed. However, cases created at a later time are not indexed. All jobs are scheduled but not completed. The Queue Processors (agents) list indicates this and displays the on-screen error. (Starting with Pega 8.1, Queue Processor rules replace the standard agents of earlier releases.)
Error Messages
Stream service is down. The values displayed on this page may be inaccurate.
Steps to Reproduce
- Upgrade from Pega 7.3 to Pega 8.1.
- Enable Search for a node.
Root Cause
A software use or operation error whereby the user did not configure the Stream service for the search-enabled node. Consequently, the pyFTSIncrementalIndexer queue processor (agent) did not run.
From Pega 8.1 and later releases, Search runs through the Queue Processor (that is, Kafka and Real-time Decisioning Services). Therefore, you need to enable the Stream service on the Services landing page.
Resolution
- From Dev Studio > Decisioning Services landing page > Decisioning > Infrastructure > Services > Stream add a Stream service.
- Go to the Admin Studio and start the Queue Processor rule pyFTSIncrementalIndexer.
- Make sure that the Queue Processor does not show the error message "Stream service is down."
- Restart the Pega server node.
Published January 29, 2019 - Updated December 2, 2021
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