Support Article
Search is not working as expected with Pega 7.1.8
SA-22839
Summary
When searching for a particular rule from the search option in the top right corner of the designer studio, no results are returned.
Using the "old:" prefix works fine.
Error Messages
Not Applicable.
Steps to Reproduce
Search any rule through search option.
Root Cause
indexing/distributed/enabled was set to False value.
Resolution
- Under "Index Administration", index Rules and Work. One can check the status of this by clicking "Check". If they have not been indexed, index each one (this will have to be done one at a time).
- Under "Search Index Host Node Setting" ensure "Search Index Host Node ID" matches the entry in the clipboard in System Pages: pxProcess: pxSystemNodeID. If one has more than one node, check the clipboard for each server. The Search Index File Directory should also exist on each server.
- Under "Query Settings" the "Degree of Fuziness" set it to "Auto"
- Under "Automated Search Alerts" tick the checkbox for "Automatically Monitor Files".
- If one changes any of these settings (or indexed rules), click the Submit button after all the actions are complete.
- On the Dynamic System Settings page, the following parameters must be set to true:
indexing/distributed/enabled = true
indexing/distributed/index_enabled = true
indexing/distributed/search_enabled = true
indexing/distributed/index_enabled = true
indexing/distributed/search_enabled = true
Published May 12, 2016 - Updated October 8, 2020
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