Support Article
Search for a work object does not work
SA-80882
Summary
Search for a work object does not work.
Error Messages
Not Applicable
Steps to Reproduce
Not Applicable
Root Cause
Instances of the below classes were missing. As a result, the Queue processor could not process the message. Hence, the Search did not work.
Class Name | Instance |
Data-Decision-Service-ADM | DEFAULT |
Data-Decision-Service-Aggregation | DEFAULT |
Data-Decision-Service-DataFlow | BACKGROUNDPROCESSING |
Data-Decision-Service-DataFlow | BATCH |
Data-Decision-Service-DataFlow | DEFAULT |
Data-Decision-Service-DataFlow | REALTIME |
Data-Decision-Service-DataFlow | SEARCH |
Data-Decision-Service-DDS | DEFAULT |
Data-Decision-Service-VBD | DEFAULT |
Data-Decision-Service-StreamServer | DEFAULT |
Resolution
Perform the following local-change:
- Navigate to Records > Sysadmin > Product.
- Create a Product rule and include all the above classes.
- In the Test or Production environment, import the Product rule file.
- Truncate the pr_sys_statusnodes table.
- Restart the server.
Published August 19, 2019 - Updated December 2, 2021
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