Support Article
Slow performance of InvokeMQConnector activity
SA-31994
Summary
User is on Pega 7.1.6 and reported the following issues:
- Lot of Pega0020 alerts in the ALERT logs for the Connect-MQ call.
- The InvokeMQConnector activity is overridden in the application ruleset and is taking close to 2 seconds for execution. The version of InvokeMQConnector activity present in 'Pega-IntegrationEngine:07-10-01' ruleset takes around the same time as the customized version of this activity but the Out-of-the-box (OOTB) version of the same activity present in Pega-IntSVcs ruleset takes 200 ms.
Error Messages
Not applicable
Steps to Reproduce
- Use Connect-MQ call from the activity.
- Run the tracer to see that OOTB version of InvokeMQconnector activity present in 'Pega-IntegrationEngine:07-10-01' ruleset has slow performance.
Root Cause
A defect or configuration issue in the operating environment is identified as root cause of the issue.
Maximum time was consumed while waiting to receive the response from external system as observed from the high value of pxConnectClientResponseElapsed counter.
The following is a sample snippet from the PegaALERT logs showing this:
RULE-CONNECT-MQ ORG-CARD- GETRECENTACCOUNT #20140615T204636.439 GMT has exceeded the threshold of 250 ms: 635 ms;pxConnectOutMapReqElapsed=1;pxConnectClientResponseElapsed=602;pxConnectInMapReqElapsed=3;
Resolution
It is recommended to contact the team owning the MQ Service for investigation related to delay caused by external system to respond back to Pega.
Published January 10, 2017 - Updated October 8, 2020
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