Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Slow response from PRPC due to static content not being cached



Slow response from PRPC due to static content not being cached

Error Messages

Users are seeing long spinning circle on the browser and the "[domain] is not responding" message is displayed at the bottom of the screen. 

Steps to Reproduce

Any user interactions in PRPC

Root Cause

The static content (js files, images, Cab files, etc...) is being fetched everytime because of the "pragma: no cache" is inserted to each response by the application server.


Set the application server "disableProxyCaching" option to "false".

For example, on Tomcat, add the following to the context.xml:
<Valve className="org.apache.catalina.authenticator.NonLoginAuthenticator" disableProxyCaching="false"/>

On JBoss EAP 4 and EAP 5, add the following to the context.xml:
<Valve className="org.apache.catalina.authenticator.FormAuthenticator" disableProxyCaching="false" securePagesWithPragma="false"/>

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us