Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Slowness when creating or saving rules in CWS framework

SA-11017

Summary


Application developers observe, while working in the Pega 7.1.7 env, slowness in the system when attempting to create new rules instances, or to save a rule instance.  Specifically, the developers observe slowness lasting longer than one minute before the system acknowledges the save operation.  The rule does save, but the time to save is very long.


Error Messages


No error messages are observed on the screen.

The Pega Logfile does contain possibly related error messages: the Search feature is reporting errors:


2015-05-07 00:26:18,345 [ttp-/0.0.0.0:18080-5] [  STANDARD] [         CL:01.01.01] (Search.Data_Find_Search.Action) ERROR <hostname>|<ipv4_address> <operatorID> - Search request failed. Query: [*name*], Index [RULE]. Possible cause: Master node is not reachable.
2015-05-07 00:26:25,143 [ttp-/0.0.0.0:18080-3] [  STANDARD] [         CL:01.01.01] (Search.Data_Find_Search.Action) ERROR <hostname>|<ipv4_address> <operatorID> - Search request failed. Query: [*name*], Index [RULE]. Possible cause: Master node is not reachable.
2015-05-07 00:26:31,695 [ttp-/0.0.0.0:18080-5] [  STANDARD] [         CL:01.01.01] (Search.Data_Find_Search.Action) ERROR <hostname>|<ipv4_address> <operatorID> - Search request failed. Query: [*name*], Index [RULE]. Possible cause: Master node is not reachable.
2015-05-07 00:27:25,781 [ttp-/0.0.0.0:18080-5] [  STANDARD] [         CL:01.01.01] (Search.Data_Find_Search.Action) ERROR <hostname>|<ipv4_address> <operatorID> - Search request failed. Query: [*name*], Index [RULE]. Possible cause: Master node is not reachable.
2015-05-07 00:27:29,510 [ttp-/0.0.0.0:18080-3] [  STANDARD] [         CL:01.01.01] (Search.Data_Find_Search.Action) ERROR <hostname>|<ipv4_address> <operatorID> - Search request failed. Query: [*name*], Index [RULE]. Possible cause: Master node is not reachable.
2015-05-07 00:27:31,237 [ttp-/0.0.0.0:18080-5] [  STANDARD] [         CL:01.01.01] (Search.Data_Find_Search.Action) ERROR <hostname>|<ipv4_address> <operatorID> - Search request failed. Query: [*name*], Index [RULE]. Possible cause: Master node is not reachable.


Note that the Pega ALERT log is rife with PEGA0020 ALERTs exceeding two minutes  Example:

RULE-CONNECT-SOAP organization-division-group- PZGETPMFASSIGNMENTS #20130919T020034.681 GMT has exceeded the threshold of  1,000 ms: 124,149 ms;pxConnectOutMapReqElapsed=0;pxConnectClientResponseElapsed=124142;pxConnectInMapReqElapsed=0;

Steps to Reproduce


This issue appears limited to creating new rule instances, and the process of saving any rule instance.  No other specific developer operations within the Developers Portal has been observed to be effected.

Root Cause


Even though it would seem that the CONNECT-SOAP operations would be completely unrelated to saving rule instances, implementation of the below identified local change appeared to resolve the issue.  Also note that the customer was advised to perform specific steps to confirm the configuration of the Lucene Search functionality.  Those steps were:

- Ensure that the Search Node ID on each PRPC instance was defined to point at the ONE PRPC instance hosting the Lucene Search engine.
- Ensure that the PRPC Search Node (the PRPC instance hosting the Lucene Search Functionality) is online and responsive.


Resolution


To resolve this issue, the cutomer implemented the following local change: on the PRPC 7.1.7 System Settings browser window, tab PROJECT MANAGEMENT, the check boxes for FEEDBACK, PROJECT TRACKING, and PMF PRODUCT should be unchecked for the specific customer rulesets that DO NOT use the Pegasystems Project Management Framework (PMF) product.

The customer confirmed that several of these check boxes were selected on their custom rulesets where the framework functionality WAS NOT being used.

After de-selecting these check boxes, and then performing a shutdown/restart of the PRPC node, Developer Portal Performance returned to normal.  Followup examination of the Pega ALERT log clearly showed that the previously identified alerts were also no longer appearing, thereby indicating expected/advertised performance.

Published July 7, 2015 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us