Support Article
SMA Error :The type java.util.Map$Entry cannot be resolved
SA-21273
Summary
System Management Application (SMA) gives below error while loading in Pega 7.1.9:
<%@page contentType="text/html" import="com.pega.jmx.connection.managenodes.NodeManager,java.net.URLEncoder,java.util.TreeMap,java.util.Hashtable,java.util.Iterator,javax.management.ObjectName,com.pega.jmx.connection.managenodes.Node"
DisplayNodes.jsp:153:15: java.util.Arrays cannot be resolved to a type
java.util.Arrays.sort(nodes);
Error Messages
DisplayNodes.jsp:80:41: The type java.util.Map$Entry cannot be resolved. It is indirectly referenced from required .class files
<%@page contentType="text/html" import="com.pega.jmx.connection.managenodes.NodeManager,java.net.URLEncoder,java.util.TreeMap,java.util.Hashtable,java.util.Iterator,javax.management.ObjectName,com.pega.jmx.connection.managenodes.Node"
DisplayNodes.jsp:153:15: java.util.Arrays cannot be resolved to a type
java.util.Arrays.sort(nodes);
Steps to Reproduce
- Use Pega 7.1.9
- Open SMA
- Error is observered in the left Panel, where the nodes should show up.
Root Cause
SMA deployed in a container running JDK version1.8.
Resolution
Deploy SMA to run against JDK with version 1.7.
Published March 23, 2016 - Updated October 8, 2020
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