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Support Article

SMA Remote Error invoking MBean operation on JBoss EAP 6.x

SA-23643

Summary



System Management Application (SMA) Extract Rule Functionality causes an error when invoked on a JBoss EAP 6.4.remote node.
The remote node is configured using  the 
JBoss Remoting protocol using the server URL service:jmx:remoting-jmx://{host_name}:{port} 
Connectivity is working fine and SMA correctly shows the remote node details.

Error Messages



The screen shown by SMA is as follow:

SMA Error on screen

The error message is:

com.pega.jmx.ui.util.JMXClientException: Failed to invoke MBean operation
Failed to invoke an operation
java.lang.Exception: Failed to invoke MBean operation.
Name: com.pega.PegaRULES:id="cb393bb0a39339a8f1048e66747342b7",name=com.pega.pegarules.management.internal.RuleUtilityLibraryExtractor,type=enterprise opName: ExtractLibrary
Unable to invoke invoke(), status=WAITING


Stack Trace:
com.pega.jmx.ui.util.JMXClientException: Failed to invoke MBean operation
Failed to invoke an operation
java.lang.Exception: Failed to invoke MBean operation.
Name: com.pega.PegaRULES:id="cb393bb0a39339a8f1048e66747342b7",name=com.pega.pegarules.management.internal.RuleUtilityLibraryExtractor,type=enterprise opName: ExtractLibrary
Unable to invoke invoke(), status=WAITING
at com.pega.jmx.ui.util.JMXClientException.wrap(JMXClientException.java:49)
at com.pega.jmx.ui.util.JMXClientUtil.invokeOpByName(JMXClientUtil.java:268)
at com.pega.jmx.ui.action.PerformRuleUtilityLibraryOpAction.execute(PerformRuleUtilityLibraryOpAction.java:88)
...
Caused by: java.lang.Exception: Failed to invoke MBean operation.
Name: com.pega.PegaRULES:id="cb393bb0a39339a8f1048e66747342b7",name=com.pega.pegarules.management.internal.RuleUtilityLibraryExtractor,type=enterprise opName: ExtractLibrary
Unable to invoke invoke(), status=WAITING
at com.pega.jmx.connection.managenodes.Node.invoke(Node.java:103)
at com.pega.jmx.ui.util.JMXClientUtil.invokeOpByName(JMXClientUtil.java:259)
... 75 more


Steps to Reproduce

  1. Click a node in SMA.
  2. Click Administration.
  3. Click Rule Utility Library Extractor.
  4. Click Extract Libraries.


Root Cause



A third-party product issue.

Root cause of the issue is a network timeout occurring in the JBoss remoting-jmx library when invoking a MBean operation on a remote PRPC node.
The JBoss library throws an IOException returning a WAITING status result when the operation invoked takes more than the default timeout, .

The default timeout used by the JBoss JMX Remoting library in JBoss EAP 6.3 systems is 60 seconds.
Different JBoss EAP 6 versions may use other values for the default timeout.

 

Resolution



Make the following change to the operating environment: 

1. The timeout can be increased using the "org.jboss.remoting-jmx.timeout" JVM system argument.
The value is expressed in seconds.
2. Modify the JAVA_OPTS environment variable to provide a sensible value for the timeout argument.
For example to set a 10 minutes timeout, add the "-Dorg.jboss.remoting-jmx.timeout=600" JVM argument to JAVA_OPTS environment variable defined in the JBoss standalone.conf configuration file

 

Published May 25, 2016 - Updated October 8, 2020

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