Support Article
SurveyManagement harness not working when used in custom portal
SA-71435
Summary
When creating a portal that refers to the out-of-the-box harness rule, SurveyManagement (Pega-Landing-PegaSurvey-SurveyManagement), and navigating to the portal, the below issues occur:
- Under the Survey tab, the existing surveys are not populated by default. However, when a user navigates to either the question page or question tab and then clicks the Refresh button, the existing surveys are populated under the Survey tab
- On click of the survey name under the Survey tab:
- The landing page opens inside the Designer studio when the logged in user has developer access
- No action occurs on accessing as a non-developer user
Error Messages
Not Applicable.
Steps to Reproduce
- Create a portal and call the harness rule, SurveyManagement (Pega-Landing-PegaSurvey-SurveyManagement).
- Add the portal in the Access Group and navigate to the portal. The Survey Management screen is loaded in the portal with the Survey, Question Page and Question tabs
- Click the Survey tab. The existing survey names which are already created are not populated when the portal is loaded. However on navigating to either question page or question and then clicking the Refresh button, the survey names are populated under the Survey tab
- Click the survey name under the Survey tab
Root Cause
An issue in the custom application code or rules. The out-of-the-box SurveyManagement harness cannot be used as is for a single threaded model in a custom portal. It requires a multi threaded model to support CRUD (create, read, update and delete) operations on the Survey rules.
Resolution
An enhancement request, FDBK-29714, has been created for consideration by Pega Product Management.
Published April 12, 2019 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.