Support Article
Switch to a new application using redirect and Run does not work
SA-27976
Summary
When switching to a new application in a new tab using the Redirect and Run activity, the harness that's initially launched is loaded correctly but if there are buttons or links which loads another harness as a new document or replaces existing window then the system throws an error.
Error Messages
There has been an issue; please consult your system administrator
Steps to Reproduce
- Use Redirect and run to launch a new application harness of a different access group in a new tab.
- In the new harness have some buttons configured on click of which another harness is launched.
Root Cause
An issue in the custom application code or rules.
The product is not designed to allow multiple tabs (which are really multiple UI Dynamic Containers) present in the same portal at the same time yet with different Access Groups.
Resolution
Instead of opening a new harness in a new tab, change the interface to "pop up" or "replace current" to produce a working use case.
Published September 15, 2016 - Updated October 8, 2020
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