Support Article
System becomes unresponsive
SA-32274
Summary
PRPC environment performance decays and intermittantly becomes unresponsive.
Error Messages
at org.jboss.netty.channel.SimpleChannelUpstreamHandler.handleUpstream(SimpleChannelUpstreamHandler.java:112)
at org.jboss.netty.channel.DefaultChannelPipeline.sendUpstream(DefaultChannelPipeline.java:564)
at org.jboss.netty.channel.DefaultChannelPipeline$DefaultChannelHandlerContext.sendUpstream
(DefaultChannelPipeline.java:791)
at org.jboss.netty.handler.codec.frame.FrameDecoder.exceptionCaught(FrameDecoder.java:377)
Steps to Reproduce
Unknown
Root Cause
This is the Decision Strategy Manager DNODE performance problem.
Resolution
Perform the following local-change:
- Do not use Decision Strategy Manager to disable the functionality.
- Log in to a Process Commander NODE as [email protected].
- Select RECORDS / SYSADMIN / DYNAMIC SYSTEM SETTINGS in the widget area (left side of browser).
- Look for the existing key: PRCONFIG/INITSERVICES/DNODE/DEFAULT.
- Set this value to FALSE. This value is set to TRUE by default.
- Log out of Process Commander.
- Shutdown ALL Process Commander Nodes.
- Contact the Java Application Administrator. Delete the following file for each Process Commander Node: ${EXPLICIT TEMP DIRECTORY}/PegaRULES_Extract_Marker.txt
- Restart All Process Commander Nodes.
Published February 24, 2017 - Updated October 8, 2020
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