Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

System error on startup after upgrading from PRPC 5.5 SP1

SA-16161

Summary



After upgrading from PRPC 5.5 SP1 to Pega 7.1.8 and when tried to start the system, it fails because the system name of developer is used.
 

Error Messages



Caused by:
com.pega.pegarules.pub.context.InvalidConfigurationException: Data-Admin-Requestor instance "devxyz!BATCH" not found
From: (B02DF0CD44CEAB7492A73A2EBF06E2856)
at com.pega.pegarules.session.internal.authorization.SessionAuthorization.reset(SessionAuthorization.java:450)
at com.pega.pegarules.session.internal.authorization.SessionAuthorization.<init>(SessionAuthorization.java:245)
... 72 more


Steps to Reproduce



Upgrade from PRPC 5.5 SP1 to Pega 7.1.8 and try to start system.


Root Cause



If the Dynamic System Setting for the default systemName is not set, the upgrade code is setting it to developer system name instead of PRPC.  This is fixed in a later release.

Resolution



Perform the following local-change: 

1.Override the system name in the prconfig.xml file with the default value of "prpc" or a valid system name for this environment.

<env name="identification/systemName" value="prpc" />

2.Restart the system and then update the dynamic system setting to match the correct system name. 

Once the dynamic system setting has been updated the entry from prconfig.xml can be removed.

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us