Support Article
Triggers are unavailable even though they are present in Pega DB
SA-11064
Summary
User has migrated from PRPC 6.2 to Pega 7.1.7. System indicates that triggers are not available even though they are present in Pega database.
The tables mapped to Rule- classes must have triggers defined on them to update the pr4_rule_vw table. Below is a list of the rule tables on which few triggers miss to update pr4_rule_vw table.
Check with the Database Administrator to define the appropriate triggers on these rule tables similar to the ones on pr4_rule table.
PCA_RULE_ASSOC_DIALOG
PCA_RULE_KNOWCONT
PCA_RULE_ASSOC_CTIP
PCA_RULE_ASSOC_KNOWCONT
PCA_RULE_DIALOG
Error Messages
Not Applicable
Steps to Reproduce
Run 'PRPC Schema report' from Developer portal to observe the issue.
Root Cause
The root cause of this problem is a defect in User's application code/rules. Application was upgraded and moved from single schema to split schema implementation. During this process PR4_RULE table in data schema should have been deleted but it was not.
Resolution
This issue is resolved by making the following change to the operating environment.
There should be only one PR4_RULE table in RULES schema in a Pega Split Schema environment. Delete the PR4_RULE from DATA schema to resolve the problem.
Published June 24, 2015 - Updated October 8, 2020
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