Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Two hyphens (--) for the Currency controls readonly fields



User is using OOTB "currency" control to display currency values and when value is empty it is showing blank but the requirement is to show "--"(two hyphens) instead of blank.
In OOTB "Input Text" when no value is there, it shows "--" .User wants this feature to be there for "Currency" control also. 

Error Messages


Steps to Reproduce

1)Create one read only field with "InputText" control and one more read only field with "Currency" control.
2)Run the case.The default value for Text Input control is displayed as "--" and the default value for Currency control is displayed empty.

Root Cause

The default value of Text Input property created as Read only displays "--"[two Hyphens] whereas for Currency it is empty. This is expected behaviour.
To modify the display of currency control default behaviour user needs change the configuration settings.



This issue is resolved through the following local change:

To display the "--"   for "Currency" control field in read only mode as default value, change the Read Only Format to "Text".

Published July 8, 2015 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us