Support Article
UI style elements in PrintView are not being printed
SA-6245
Summary
Developer has style elements applied to his preview and print harnesses. Specifically, he has a background color set for his section headers. When he prints (either hardcopy or PDF), the header backgrounds are not printed.
In PrintView harness:

In PDF file:

Error Messages
Not applicable
Steps to Reproduce
1. Open the perform harness, click the Print icon to bring up the Printview harness.
2. Print the harness to either a PDF file or actual hardcopy.
Root Cause
The root cause of this problem is defect/misconfiguration in the PRPC operating environment. Browser option to print background colors and images must be enabled.
Resolution
This issue is resolved through the following local change: Enable browser option to print background colors and images.
In IE9:
1) Select File->Print preview...

2) In the Print Preview window, click the 'Gear' icon (Page Setup):

3) In the Page Setup dialog, enable the "Print Background Colors and Images" option:

Published January 31, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.