Support Article
UI style elements in PrintView are not being printed
SA-6245
Summary
Developer has style elements applied to his preview and print harnesses. Specifically, he has a background color set for his section headers. When he prints (either hardcopy or PDF), the header backgrounds are not printed.
In PrintView harness:
![](https://gcsprdsa.lab.pega.com/articles/datacontent/Image/rteImages/PrintView1423598395620.jpg)
In PDF file:
![](https://gcsprdsa.lab.pega.com/articles/datacontent/Image/rteImages/PDF1423848380413.jpg)
Error Messages
Not applicable
Steps to Reproduce
1. Open the perform harness, click the Print icon to bring up the Printview harness.
2. Print the harness to either a PDF file or actual hardcopy.
Root Cause
The root cause of this problem is defect/misconfiguration in the PRPC operating environment. Browser option to print background colors and images must be enabled.
Resolution
This issue is resolved through the following local change: Enable browser option to print background colors and images.
In IE9:
1) Select File->Print preview...
![](https://gcsprdsa.lab.pega.com/articles/datacontent/Image/rteImages/File1423599739365.jpg)
2) In the Print Preview window, click the 'Gear' icon (Page Setup):
![](https://gcsprdsa.lab.pega.com/articles/datacontent/Image/rteImages/Print Preview1423599861629.jpg)
3) In the Page Setup dialog, enable the "Print Background Colors and Images" option:
![](https://gcsprdsa.lab.pega.com/articles/datacontent/Image/rteImages/Page Setup1423599956181.jpg)
Published January 31, 2016 - Updated October 8, 2020
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