Support Article
Unable to connect to JFrog repository
SA-88654
Summary
Error occurs when saving a rule with JFrog HostID, Repository key, and Authentication profile.
Error Messages
Could not connect to repository
Steps to Reproduce
- Create a Repository rule.
- Configure the Repository type as JFrog.
- Enter the HostID, Repository Key, and Authentication Profile.
- Click Save to create the rule.
Root Cause
A defect or configuration issue in the operating environment.
The JFrog Repository used an HTTPS URL and the SSL certificates were not added to the Java Store of the Pega Server.
Resolution
Perform the following local-change:
For the Java Runtime Environment (JRE) to trust the certificate, perform the below steps to import the certificate to the JRE Certificate store:
- Browse to the JFrog Repository using SSL. The browser informs the user that the certificate is not trusted and allows the user to trust it, thereby placing it in the browser Certificate store. The browser has a Certificate Manager that allows the user to export or back up specific certificates to binary files.
- In the Firefox browser, navigate to Preferences > Advanced > Encryption > Servers.
- Locate the certificate presented by the server and export it as a binary DER file.
- Ensure to have Write access to Pega Server's JRE and use the KeyTool utility to import it using the following command:
keytool -import -alias alias -keystore path-to-jre/lib/security/cacerts -file path-to-certificate-file
The user is prompted for the Keystore password which is by default 'changeit'.
Additionally, when the user connects to the server, the user must use the same name as the one set in the Subject in the certificate. The user must add it to the host file if the server is not reachable using this name, which may be the case for a Developer server.
Published December 2, 2021
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