Support Article
Unable to connect to SMA node due to LinkageError
SA-26337
Summary
User is unable to connect to a Pega node (remote connection) from System Management Application (SMA) due to a java.lang.LinkageError.
WebSphere [IBMJAVA71 7.1.3.30 cf091608.04]Platform 8.5.5.9 [ND 8.5.5.9 cf091608.05]
Host Operating System is AIX, version 7.1
Java version = 1.7.0, Java Runtime Version = pap6470_27sr3fp30-20160112_01 (SR3 FP30), Java Compiler = j9jit27, Java VM name = IBM J9 VM
Error Messages
[6/17/16 10:29:36:702 EDT] 0001957d Dispatcher E org.apache.struts2.dispatcher.Dispatcher error Exception occurred during processing request: null
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
..
Caused by: java.lang.LinkageError: com/ibm/websphere/management/AdminClient.queryNames(Ljavax/management/ObjectName;Ljavax/management/QueryExp;)Ljava/util/Set;
at com.pega.jmx.connection.managenodes.WASRemoteMBeanServerConnection.queryNames(WASRemoteMBeanServerConnection.java:131)
Steps to Reproduce
Setup a remote connection in SMA and attempt to connect to it.
Root Cause
A third-party product issue. Automated Websphere deployment script was in use for SMA app deployment instead of the manual deployment recommended in the install guide.
Resolution
Make the following change to the operating environment: Deploy SMA using Websphere console, as documented in the install guide.
Refer to the section with title : "Deploy the System Management and Online Help Applications "
Published August 17, 2016 - Updated October 8, 2020
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