Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Unable to establish session with SMSC Server and send out SMS

SA-8157

Summary



User has configured SMS gateway for an SMPP connection and has created a Channel - SMS Outbound Connection and an SMS Account for the same. They were able to connect to the Server and disconnect but he is getting a failure to establish a session and push the SMS to the Server.

Error Messages



Initialise session for connection to SMS server Success
Establish session to SMS server Fail
Send message to test number Not attempted
Disconnect Success


Steps to Reproduce



NBAStudio Portal -> Channels -> SMS -> Outbound SMS. Create New connection.
Create an SMS Account for that connection.
Configure a server to access. (SMS Gateway)
Apply configuration details for server in SMS Connection and Account.


Root Cause



The error was connect - java.net.ConnectException: Connection refused, and system administrator have been requested to look at the SMSC Server end configuration, port and firewall issues.

Resolution



After adding an exception to the firewall, the behaviour got resolved.

Published January 31, 2016 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice