Support Article
Unable to localize Confirm message on Confirm harness
Summary
Unable to localize the below Confirm message on the Confirm harness.
'This item has been resolved'
Error Messages
Not Applicable
Steps to Reproduce
- Execute a General task.
- Resolve the case. On the Confirm harness, the 'This item has been resolved' message displays.
- Create a FieldValue for 'This item has been resolved' for the FieldName pyConfirmationNote.
- Apply localization.
Root Cause
An issue in the custom application code or rules.
When the Field Values are not created on the correct FieldNames, the localized values are not retrieved.
Resolution
Perform the following local-change to localize a label:
- Create a Field Value with pyCaption as FieldName.
- Call FieldValue in Label cell properties.
For example: The user attempts to localize the below label in the Confirm harness
'This item has been resolved'
- Create a FieldValue for ‘This item has been resolved.’ for pyCaption.
- Identify the section containing the ‘This item has been resolved' label. In this case, the Section rule name is pyConfirmationMessage.
- Open the section and open the Cell properties for the label.
Set Value to <pega:lookup property='.pyConfirmationNote'/>
- From the dropdown, select the FieldValue created.
Select the ‘This item has been resolved' option.
The updated Label Value field and the Section rule display as below.
- Save the Section rule and execute the use case. The localized values display.
Published October 5, 2019 - Updated December 2, 2021
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