Support Article
Unable to log in on iOS 9 and 10 after a period of inactivity
SA-60556
Summary
Unable to log in to the application on iOS 9 and 10 devices after a period of inactivity. An endless loop of login prompts occurs.
Error Messages
Not Applicable.
Steps to Reproduce
- Log in to the application
- Allow the authentication to timeout
- Attempt to log back in
Root Cause
A defect in Pegasystems’ code or rules. In certain configurations, SMSession cookies were duplicated due to iOS hybrid client code that was responsible for cookie synchronization between native implementation and WKWebView.
Resolution
Re-build mobile hybrid client with version 7.31.4.22 or above.
Published July 23, 2018 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.