Support Article
Unable to start agent with Pega 7.1.7
Summary
It is noticed that shortly after starting an agent from the System Management Application, the agent is terminating processing and not restarting. Errors coupled to the custom agent are seen in the log.
Error Messages
Ruleset:Version] (ernal.async.BatchRequestorTask) ERROR - Batch activity "Class.CustomActivity" threw:
com.pega.pegarules.pub.runtime.ActivityTerminateException: This is a singleton exception object and the stack trace below does NOT reflect the actual point of failure. To see the actual trace, set Initialization/UniqueActivityTerminateExceptions = true
Steps to Reproduce
- Log in to the System Management Application.
- Navigate to the agents area and select the radio button coupled to the agent in question.
- Click on the Start button at the top of the screen.
- Observe the agent eventually terminates and shows it as not actively running. The "Runnable?" column displays a red X.
Root Cause
An issue in the custom application code or rules. The custom agent activity has a conditional step that executes an Activity-End method. This method, when used within an agent, is expected to bring down the agent as seen in this case.
Resolution
Replace the Activity-End method with Exit-Activity.
In this use case, the functional behavior desired is to exit the activity when a certain condition is present. This goal is met with the above substitution.
The solution above is mentioned in the following support article:
https://pdn.pega.com/support-articles/employee-feed-agent-crashes-without-executing
Published August 24, 2016 - Updated October 8, 2020
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