Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Unable to start agent with Pega 7.1.7

SA-26543

Summary



It is noticed that shortly after starting an agent from the System Management Application, the agent is terminating processing and not restarting. Errors coupled to the custom agent are seen in the log.

Error Messages

Ruleset:Version] (ernal.async.BatchRequestorTask) ERROR - Batch activity "Class.CustomActivity" threw:
com.pega.pegarules.pub.runtime.ActivityTerminateException: This is a singleton exception object and the stack trace below does NOT reflect the actual point of failure. To see the actual trace, set Initialization/UniqueActivityTerminateExceptions = true


Steps to Reproduce

  1. Log in to the System Management Application.
  2. Navigate to the agents area and select the radio button coupled to the agent in question.
  3. Click on the Start button at the top of the screen.
  4. Observe the agent eventually terminates and shows it as not actively running. The "Runnable?" column displays a red X.


Root Cause



An issue in the custom application code or rules. The custom agent activity has a conditional step that executes an Activity-End method. This method, when used within an agent, is expected to bring down the agent as seen in this case. 

Resolution



Replace the Activity-End method with Exit-Activity.
In this use case, the functional behavior desired is to exit the activity when a certain condition is present. This goal is met with the above substitution.

The solution above is mentioned in the following support article:
https://pdn.pega.com/support-articles/employee-feed-agent-crashes-without-executing

Published August 24, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us