Support Article
Unable to start application server after upgrade to PRPC v7.1.7
SA-4859
Summary
Developer upgraded PRPC application from PRPC v6.1 SP2 to PRPC v7.1.7. From database perspective, upgrade operations went fine. After deploying PRPC v7.1.7 EAR file, user was unable to start the application server.
Error Messages
Below error is thrown in PegaRules log file
[12/20/14 18:19:18:904 EST] 00000017 SystemOut O 2014-12-20 18:19:18,902 [ ip-10-166-12-68] [ STANDARD] [ ] [ ] (etier.impl.EngineStartup) ERROR - PegaRULES initialization failed. Server: ip-10-166-12-68
com.pega.pegarules.pub.context.InitializationFailedError: PRNodeImpl init failed
[12/20/14 18:19:18:905 EST] 00000017 SystemOut O 2014-12-20 18:19:18,904 [ip-10-166-12-68] [ STANDARD] [ ] [ ] (etier.impl.EngineStartup) INFO - PegaRULES initialization failed. Server: ip-10-166-12-68
[12/20/14 18:19:18:908 EST] 00000017 SystemOut O 2014-12-20 18:19:18,908 [ip-10-166-12-68] [ STANDARD] [ ] [ ] (ervlet.WebAppLifeCycleListener) ERROR - Enterprise tier failed to initialize properly, PegaRULES not available
Steps to Reproduce
Step-1: Install PRPC v6.1SP2.
Step-2: Perform PRPC upgrade to PRPC v7.1.7.
Step-3: Once done, deploy PRPC v7.1.7 EAR file and try to start the application server.
Root Cause
While starting up application server, it’s unable to find the identification/system name details. This causes initialization failure and failed to start server.
Resolution
Configuring “prconfig / identification/systemName” to “prpc” as below, helps address this issue
<env name="identification/systemName" value="prpc" />
Published January 31, 2016 - Updated October 8, 2020
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