Support Article
Unable to view created audience segments in Pega Marketing 7.13
Summary
Unable to view Prospect instances under Audience tab in Pega Marketing Portal. The Segments Instances are listed as expected.

Error Messages
No Error Message
Steps to Reproduce
1) Create and Save a Segment of type Prospect in Pega Marketing 7.13
2) Open Pega Marketing Portal.
3) Click Audience link on the left navigation Pane
Root Cause
A defect in Pegasystems’ code or rules.
Resolution
The issue will be fixed in the next version of Pega Marketing. For Pega Marketing 7.13, apply the below local change.
1) Do Save As the following Report definitions
-Rule-Obj-Report-Definition-Segment.GetAudienceCardCount
-Rule-Obj-Report-Definition-Segment-GetAudienceCardDetails
2) Update the filter criteria for pyClassName to include both the Customer and Prospect Class, i.e. "PegaMKT-Data-Customer","PegaMKT-Data-Prospect
3) Created the following Data Transform
-Embed-PegaMKT-CardContainer-Audience.GetAllAudiences
(Screenshot assumes you called the save as of the report GetAudienceNProspect[CardDetails | Count])
4) Update the following section:
-Data-Portal-Marketing-Studio.pyPortalNav
Find the “Audience” layout. There is an Action Set on the Layout itself, not the individual text or icons.
5) Update the Action associated with the layout to call the your new Data Transform, GetAllAudiences
Tags:
Published January 31, 2016 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.