Support Article
When case is open from notify URl, look and feel is not good.
SA-11696
Summary
When case is open from user's Notification url, look and feel is not updating.
Error Messages
Look and feel is not updating.
Steps to Reproduce
1. Create the case.
2. Send notification to any party by including the Worklink in correspondence rule.
3. Click on that link.
Root Cause
The root cause of this problem is software use/operation error.
User wanted to use look and feel of case manager portal but in worklink correspondence fragment details related to skin rule was not mentioned.By default taking designer studio look and feel .
Resolution
This issue is resolved through the following local-change:
Add "pzSkinName=pyEndUser71" in worklink correspondence fragment as mentioned below:
{%
tools.putSaveValue("PublicLinkURL",pega_procom_pegaprocomutilities.getPublicLinkURL());
%}
{WHEN useDesktop}
<a target="_blank" href="{$save(PublicLinkURL)}?pyActivity=Work-.Open&Action=Review&HarnessPurpose=Review&pzSkinName=pyEndUser71&InsHandle={%
try {
appendString(pega_rules_utilities.encodeURLParameter(tools.getDatabase().getHandle(tools.getStepPage())));
} catch(DatabaseException de) { appendString(pega_rules_utilities.encodeURLParameter(tools.getProperty(".pzInsKey").getStringValue())); }
%}">{.pyID}</a>
{ELSE}
<a target="_blank" href="{$save(PublicLinkURL)}?pyActivity=Work-.Open&Action=Review&InsHandle={%
try {
appendString(pega_rules_utilities.encodeURLParameter(tools.getDatabase().getHandle(tools.getStepPage())));
} catch(DatabaseException de) { appendString(pega_rules_utilities.encodeURLParameter(tools.getProperty(".pzInsKey").getStringValue())); }
%}">{.pyID}</a>
{/WHEN}
Published February 27, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.