Support Article
Work object lock released incorrectly
SA-8254
Summary
A user opens a case and clicks on the close button. Another user tries to access the same case after 20 minutes, the system displays an error stating that the case is locked by the first user.
Error Messages
Case is being modified by User
Steps to Reproduce
1. First user logs in, opens a case, and clicks the close button.
2. Another user logs in and tries to access the same case after 20 minutes.
Root Cause
PRPC has both hard and soft locks for Work Objects. The hard lock holds until the default session timeout gets expired for the user who keeps the work object open in editing mode. The hard lock details is found in the pr_sys_locks table.
Lock is determined by a setting on the System form (Data-Admin-System class). Locks held for longer than this interval are marked as "soft" and may be forcibly released, even when the requestor session is active and processing. Locks held for long intervals may indicate looping or design problems. The same can be found in this PDN help file - https://pdn.pega.com/sites/default/files/help_v63sp1/Default.htm#definitions/t/timeouts.htm.
Resolution
Following configuration are suggested while configuring soft locks:
1. Modify the lock timeout setting on the System record (Data-Admin-System class).
2. Add the below configuration to avoid the soft lock issues due to caching in multi-node PRPC environment.
<env name="database/lockcache/enabled" value="false"/>
Published January 31, 2016 - Updated October 8, 2020
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