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Support Article

Work object tabs issue in different scenarios

SA-36024

Summary



Application is build on Pega 7.2.1 using Customer Service for Financial Services 7.2.1 (CPM FS).

In the implementation of GetNextWork and Navigation links to open work object, multiple work Object tabs are opened instead of one single work object tab.


Error Messages



Not Applicable


Steps to Reproduce



1) Launch CPM Manager Portal or Interaction portal.
2) Click on a link that calls "Create work object" or that calls "GetMostUrgent".

On click of the link, two tabs of same work object is opened instead of a single work object.


Root Cause



On analysis, observed that in the custom portal, customer had added the scripts from both CSR portal and the interaction portal.

The issue was with CPMGeneralWorkGadget section, initialize the create work calling two times.

Resolution



Apply HFix-33445 to resolve the issue.

Published May 4, 2017 - Updated December 2, 2021

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