Support Article
Search functionality does not work for Delegated rules
SA-73850
Summary
The Search functionality does not work for Delegated rules in the Customer Service Interaction portal.
Error Messages
Not Applicable
Steps to Reproduce
- Delegate a few rules for an Interaction portal Required access group.
- Open the Delegated rules section from the Interaction portal.
- Input a string in the Search box.
- Press the Enter key. The system must filter the Delegated rules based on the input Search string.
Root Cause
A defect in Pegasystems’ code or rules.
The Customer Service portal's pyDisplayHarness is of the CPM-Portal class instead of the Data-Portal class. Hence, the pySearchText is empty on the pyDisplayHarness.
Resolution
Apply HFix-51186.
Published March 6, 2019 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.