Support Article
Adv Agent with queue instructions causes RuleNotFoundException
SA-9497
Summary
User has configured an advance agent with queue instructions. On executing the agent, the RuleNotFoundException is observed.
Error Messages
2015-04-29 12:43:26,113 [.PRPCWorkManager : 1] [ STANDARD] [ PegaRULES:07.10] (l.vtable.VirtualRulesTableImpl) INFO - RULE-OBJ-ACTIVITY DEMO-DATA-ATTACHMENT PYCLMPROCESSSTOREDOCUMENT #XXXX04XXT062236.448 GMT |Yes |DemoClaimsMgmt:01-02-33 |Rule-Obj-Activity |DEMO-Data-Attachment |com.pegarules.generated.activity.ra_action_pyclmprocessstoredocument_850ec93ba5d29267bcdc2a16e2baa5af
2015-04-29 12:43:26,114 [.PRPCWorkManager : 1] [ STANDARD] [ PegaRULES:07.10] (ernal.async.BatchRequestorTask) ERROR - Batch activity "DEMO-Data-Attachment.pyCLMProcessStoreDocument" threw:
com.pega.pegarules.pub.PRRuntimeError: PRRuntimeError
at com.pega.pegarules.session.internal.mgmt.base.ThreadRunner.runActivitiesAlt(ThreadRunner.java:706)
at com.pega.pegarules.session.internal.mgmt.base.ThreadRunner.runActivities(ThreadRunner.java:567)
at com.pega.pegarules.session.internal.mgmt.PRThreadImpl.runActivities(PRThreadImpl.java:425)
.
.
.
at com.pega.pegarules.session.internal.engineinterface.etier.asynchbeans.RunnableWrapper.run(RunnableWrapper.java:71)
at com.ibm.ws.asynchbeans.J2EEContext$RunProxy.run(J2EEContext.java:268)
at java.security.AccessController.doPrivileged(AccessController.java:202)
at com.ibm.ws.asynchbeans.J2EEContext.run(J2EEContext.java:768)
at com.ibm.ws.asynchbeans.WorkWithExecutionContextImpl.go(WorkWithExecutionContextImpl.java:222)
at com.ibm.ws.asynchbeans.ABWorkItemImpl.run(ABWorkItemImpl.java:159)
at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1604)
Caused by:
com.pega.pegarules.pub.generator.RuleNotFoundException: Failed to find a 'RULE-OBJ-ACTIVITY' with the name 'PYCLMPROCESSSTOREDOCUMENT' that applies to 'DEMO-Data-Attachment'. There were 1 rules with this name in the rulebase, but none matched this request. The 1 rules named 'PYCLMPROCESSSTOREDOCUMENT' defined in the rulebase are:
1 related to applies-to class 'DEMO-Data-Attachment', but were defined in rulesets which are not in your rulesetlist: 'DemoClaimsMgmt:01-02-33'.
Steps to Reproduce
1. Create Advanced Agent. Define an Activity. Place the Activity in the Agent.
2. Resume the Flow by calling another Activity and setting the Ticket.
3. In the Flow, call another Activity which has Queue method to call another Activity.
4. The Activity that is being called from the Queue instruction is not found and displays RuleNotFoundException when batch is processing the queue Activity.
Root Cause
The activity configured in the advanced Agent and Queue Activity were in different classes.
Resolution
Mention Queue ClassName.ActivityName (Queue DEMO-Data-Attachment.PYCLMPROCESSSTOREDOCUMENT) under the method signature instead of Queue PYCLMPROCESSSTOREDOCUMENT.
Published June 12, 2015 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.