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Support Article

Agent tasks stuck in status "Now-Processing"

SA-18617

Summary



User has a standard agent that is configured to run every 30 sec just in on Node. User has created a lot of tasks for the agent, about 4000.After some time user is looking for the pr_sys_queues table. User noticed all the tasks in the status "Now-Processing".


Error Messages



N/A

Steps to Reproduce

  1.  Create a standard agent.
  2. Queue a lot of tasks to it.
  3. After some time look at the pr_sys_queues table (where tasks are stored).
  4. All the tasks are in status "Now-Processing".
    Expected: Tasks are removed or updated to status broken-process or status success.



Root Cause



The issue is because the developer has overridden the queue page in their agent activity using Page-New on the primary page. So all values are getting lost. But, the value of pyItemId on the queue entry is needed for delete/update operation.

Resolution




Suggested the developer to remove the Page-New method from the activity in order to make the process work perfectly.
 

Published January 31, 2016 - Updated October 8, 2020

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