Support Article
Authentication Timeout challenge is not letting user in
Summary
Authentication timeouts challenge not letting the user in even after supplying correct credential multiple times.
Access group authentication timeout is being used and no custom authentication is configured.
Error Messages
Not applicable
Steps to Reproduce
- Configure Acces group authentication timeout to 60 secs.
- Login to portal and wait for 60 secs.
- Browser pops-up for credentials, enter valid credentials.
Root Cause
This issue is due to a default HTTP Basic authentication configuration at Weblogic level. This configuration enforces or looks for weblogic server authentication on seeing HTTP 401, meaning user need to pass Weblogic server credentials first. But user provides the Pega credentials on the first pop-up and therefore the pop-up keeps coming back.
Resolution
Make the following change to the operating environment:
The enforce-valid-basic-auth-credentials flag is true by default and WebLogic Server authentication needs to be performed on HTTP 401 Basic authentication.
Hence, user need to set the flag to false to stop asking the actual Pega user for weblogic server credentials.
Add the <enforce-valid-basic-auth-credentials> element to config.xml within the <security-configuration> element.
<enforce-valid-basic-auth-credentials>false</enforce-valid-basic-auth-credentials> (Add this just above the security config tag)
</security-configuration>
After performing this change, user have to restart all of the servers in the domain.
Published November 26, 2016 - Updated October 8, 2020
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