Support Article
Classes mapped to PegaDATA schema are not finding the tables
SA-9166
Summary
After a migration from PRPC 6.3 SP1 to Pega 7.1.7 split schema, classes mapped to the PegaDATA schema are not finding the tables in the data schema.
Error Messages
Not Applicable.
Steps to Reproduce
Upgrade PRPC 6.3 SP1 to Pega 7.1.7 split schema and start the system on WebSphere application server.
Open a class that maps to a database table in the PegaDATA schema and test connectivity.
Root Cause
The root cause of this problem is defect/misconfiguration in the operating environment.
The bindings for the defaultSchema properties were not defined at the correct scope to be seen by the system.
Also the PegaRULES datasource was being started as the rules schema user instead of the data schema user.
Resolution
This issue is resolved by making the following change to the operating environment:
- Move the PegaRULESDefaultSchema and PegaDATADefaultSchema bindings at the correct scope.
- Update the PegaRULES data source to use the data, or base user.
Published March 10, 2016 - Updated October 8, 2020
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