Support Article
Classes missing under Class Explorer post Pega 7.4 upgrade
SA-66978
Summary
Post Pega 7.4 upgrade, all classes in the work pool do not display in the Application Explorer.
Error Messages
Not Applicable
Steps to Reproduce
- Upgrade PRPC 6.3 to Pega 7.4.
- Log in to the application.
Root Cause
A backwards compatibility behavior.
In PRPC 6.3, all the classes which have same class group are fetched whether the class is in the Inheritance path or not. However, in Pega 7 platform, only those classes which have the same work pool and Inheritance path are fetched.
Resolution
Here’s the explanation for the reported behavior:
The missing classes have the work pool name but are not in the Direct or Pattern Inheritance of the work pool. Hence, the classes are not listed in the Application Explorer or work pool.
Published March 19, 2019 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.